h1

Problema con PackageKit y dependencies

diciembre 11, 2008

Ayer me di cuenta que habian varios paquetes listos para ser actualizados, asi que deje actualizando Fedora en la madrugada. Ahora al despertarme y prender la pc abri el software updater para ver si se actualizo todo y me di con un mensaje:
“failed to get a TID: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface “org.freedesktop.PackageKit.Transaction” member “SetLocale” error name “(unset)” destination “org.freedesktop.PackageKit”) (0)”

Decidi intentar por consola con yum, pero me tope con este error
ERROR:dbus.proxies:Introspect error on :1.50:/org/freedesktop/PackageKit: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.DBus.Introspectable" member "Introspect" error name "(unset)" destination ":1.50")
Unable to send message to PackageKit

Junto con
Error: Missing Dependency: libpackagekit-glib.so.10 is needed by package gnome-packagekit-0.3.9-8.fc10.
No me quedo otra que probar limpiando la metadata
yum clean all
yum clean metadata

Sin embaro tampoco hubo suerte, el problema es con una libreria de PackageKit, no quedo otra opcion que reinstalarlo.
yum remove PackageKit*
yum install PackageKit*

Muchas veces esto ayuda a reparar errores (muchas veces me ha pasado con los drivers de nvidia), pero esta vez no fue asi, es mas en FedoraForum hay un thread inmenso de este problema, por ahora hasta que no haya un nuevo update la unica solucion ha sido yumex
yum install yumex
Asi que a esperar una pronta solucion.
PD: Este error no se limita al PackageKit hay varios paquetes que han dejado de funcionar como el system-config-services

PD:Al reinstalar el packagekit no se olviden de gnome-packagekit para que lo puedan ver en gnome

7 comentarios

  1. Justo vengo saliendo de ubuntu 8.10 por que en mi computadora se cae a pedazos de lo lenta que es. Ahora vengo a Fedora y me encuentro con este error bastante molesto. Probaré tu solución a ver que ocurre.


    • Bueno yo desisti de ubuntu desde la version 6. Lo de lenta depende mucho de tu pc, el entorno grafico y las aplicaciones que uses. Prueba con el XFCE si es muy lento, lo que no te recomiendo es el KDE 4 que trae fedora 10
      Y otra cosa esto no es una solucion es mas un parche momentanio el reemplazar el packagekit por yumex


  2. Hola, me encontre con tu problema y aplique la solución que explicas. Ahora me encuentro que al ir a Sistema>Administracion no me deja actualizar el sistema. Al ir a Sistema>Preferencias tampoco me sale la opcion de automatizar la actualización. En cambio desde la consola si me deja con el comando yum update.

    Es nornmal que no me salga la aplicacion de instalar paquetes y actulizar el sistema que tenia antes? Por otro lado he visto que para instalar paquetes tengo el Yum Extender, en Aplicaciones. Este programa tambien me actualiza el sistema?

    Muchas gracias!!!!!!!


    • Bueno eso mismo me pasa a mi y a muchos mas. Todo esto es parte del error, varias cosas estan desactivadas asi que no te “preocupes” no eres el unico.
      El Yum Extender que mencionas es el yumex que recomende instalar, asi que a traves de el puedes actualizar tu fedora


  3. Desde una consola root le dí yum check-update y observé que hay actualizaciones para el PackageKit, por lo que ejecuté yum update. Se corrigió el error.

    Mi experiencia con Ubuntu 8.10 fue un poco claro obscuro, me agradó las mejoras a Gnome pero me regresé a Fedora por que sentí que tenía Windows instalado; se me congeló en 3 ocasiones.

    Saludos


  4. @fedorama: Gracias por tu respuesta. Fíjate, Ubuntu iba super bien en mi actual pc hasta la versión 7.10 y bueno quizá la 8.04 pero ahora que le puse la 8.10 la empecé a sentir muy lenta y encima el firefox se cerraba solo a cada rato. Un poco harto de la situación decidí probar Fedora y he estado siguiendo esta guía para dejarlo listo para usarse:

    http://www.howtoforge.com/the-perfect-desktop-fedora-10

    Bueno, me agradaba saber que no era el único con ese problema dado que hice como tu de quitar el PackageKit y reinstalarlo pero ahora ya no me sale en Sistema->Administración. Entonces, por lo que cuentas habrá que esperar a un fix para esto. Mientras tanto me pondré el yumex aunque ya estoy acostumbrado a hacer todo por consola jaja.

    Un saludo.


    • Como dice PioJMLin ha salido un update para el PackageKit, y para que lo puedas ver en Sistema->Administracion tienes que instalar gnome-packagekit Richard, con eso se soluciona ese problema.
      Bueno mi experiencia con ubuntu empezo mal desde que no podia escribir, el teclado funcionaba mal las teclas se repetian solas, busque informacion por todos lados nadie me daba razon y harto de la situacion abandone…y me pase a fedora desde la version 6 hasta ahora. Y no eres el unico al que se le ha congelado linux, a mi me pasaba en la laptop al usar wine en fedora 8 y 9.



Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: